Back to overview
Degraded

Update: Partial Fix Deployed for MPC Service

Jul 03 at 06:50pm CEST
Affected services
MPC - Testnet

Created
Jul 03 at 06:50pm CEST

Although the patch has mitigated part of the issue, the service is still operating in a degraded state. Users may continue to experience intermittent performance problems. Our engineering team is actively monitoring the system and working toward full resolution.

Further updates will be provided as progress continues.